DragonDreams PPA Repository

DragonDreams PPA (Linux)

The DragonDreams PPA Repository contains all Linux versions of our Software. This repository can be used for all Debian based Linux Distributions, for example Ubuntu.

The PPA Repository provides automatic updates of all software to the latest version available without waiting for distributions to pick up packages.

To install any packages from this PPA you have to add the repository to your system. You have to do this only once. You can do this using your system package manager or using a console, for example Konsole under KDE. Enter the following command and press Return/Enter at the end of the line.

sudo add-apt-repository -u ppa:rpluess/dragondreams

Now you can search for DragonDreams Software and install them using your system package manager contained in your system.

 


The following main Packages are provided

dragengine Meta package for installing the Drag[en]gine Game Engine. Installs the game engine and the GUI Launcher.

Recommended for Gamers to play games (*.delga).

delauncher-gui GUI based launcher to run games. This is the recommended launcher for gamers.
delauncher-console Console based launcher to run games. Recommended for advanced users and game server usage where a GUI launcher is not desired nor possible to be used.
deigde Development Environment for developing games using the Drag[en]gine game engine.
kdevelop-lang-dragonscript

KDevelop DragonScript Language Support Plugin for working with DragonScript files (*.ds).

Shows Declarations, Uses and Class Outlining information. Supports Code Completion with generating function calls and code block calls. Supports Code Generation for example easily overriding functions.

 


The following Packages are used to develop modules and editors. They are not required to develop games.
They are only required for creating new game engine modules and IGDE editors.

libdragengine-dev Development files required to create Drag[en]gine Game Engine Modules and Drag[en]gine Launchers.
libdeigdeshared-dev Development files required to create Drag[en]gine IGDE Editors.
libdscript-dev Development files required to write Packages for the DragonScript Language or to embed the DragonScript Language into your software project.

 


The following Packages are dependencies of the packages above and will be automatically installed if required

libdragengine1 Drag[en]gine Game Engine runtime libraries and modules.
libdeigdeshared1 IGDE shared runtime library used by IGDE and editor modules.
deigde-data IGDE shared data files (architecture independent).
libdscript1 DragonScript Language runtime. Used by DragonScript Scripting Module and DSI.